Can Warn Staff

[xF 2.0-FREE] Can Warn Staff 2.0.7

No permission to download
  • Upgrade Your Account
    Hello Guest ! Upgrade your account to download any of our premium products Here.
    How to upgrade your account to download resources Learn More.
    Guest need to read through our rules and regulations Learn More.
    Important! Read your welcome message To know how to download.
  • This material is provided by the xFhat.com site for informational purposes only. Administration is not responsible for its contents.
Compatible XF 2.x versions
2.0, 2.1
Additional Requirements
php 5.6+
Allow moderators and administrators to be warned.

AdminCP access can obviously bypass any warning issued, and warnings themselves can be edited or deleted depending on permissions for the user.

Introduces 7 new permissions:
  • Give moderators warnings directly.
  • Give administrators warnings directly.
  • Delete all warnings for Moderators.
  • Delete all warnings for Administrators.
  • Prevent posts being warned.
  • Prevent being directly warned.
  • Prevent profile posts being warned.
Performance

Requires between 0 or 1 extra queries depending on if the active members on the content to-be-warned share a permission combination group with the visitor.


Contributing features or bug fixes
Please create a Github Pull request via the "More Information" link.
Author
J0ker
Downloads
7
Views
37
First release
Last update
Rating
0.00 star(s) 0 ratings

More resources from J0ker

Share this resource

Latest updates

  1. 2.0.7 - Bugfix update

    Fix error on profile pages with XF2.1 and php 7.0+
  2. 2.0.6 - XF2.1 compatibility update

    Initial XF2.1 compatibility update
  3. 2.1.0 - Maintenance release

    Remove extra query for visitors without the Warn permission, when viewing threads or profile posts